日本語プログラミング言語ドリトルでゲームを作ろう!作れるもの4選

ドリトルでプログラミングをしてゲームを作ってみたい
自分でゲームを作るにはどうしたらいいんだろう

そんな風に考えている方も多いのではないでしょうか。ドリトルでは、ピンポンゲームや宝拾いゲームなどの簡単なゲームを作れます。

この記事では、簡単なゲームを作る方法に加えて、音楽を流す方法やチャットを作る方法についても解説します。

プログラミング言語ドリトルとは?

プログラミング言語ドリトルとは

ドリトルとは、教育現場で使うことを主な目的として作られた日本語プログラミング言語です。機械への命令を日本語で書けるので、英語が苦手な人や子供でもプログラミングを始めやすい点がメリットです。

ドリトルでは、次のようなことができます。

  • タートルグラフィックス
  • 統計処理
  • ネットワーク通信

タートルグラフィックスとは、かめを動かした軌跡を図形として描く手法のこと。ドリトルでは、タートルグラフィックスを使ってプログラミングを行います。

ドリトルでゲームを作るために覚えておきたい4つの使い方

ドリトルでゲームを作るために覚えておきたい使い方

ドリトルは、公式サイトからダウンロードが可能です。

ドリトルにはブラウザ上で利用できるオンライン版やBitArrow版、小学校での授業用に作られた「ドリトルではじめるプログラミング」もありますが、ゲームを作るのであれば、一番機能が多いインストール版を使うのがおすすめです。

ゲームを作る前に、次の4つの使い方を確認しましょう。

  • 図形の描き方
  • 色の付け方
  • ボタンの作り方
  • アニメーションの作り方

それぞれ解説します。

図形の描き方

図形の描き方

図形を描くには、画面上にかめを作り、作りたい形に動かします。例えば、三角形を描く場合には次のように書きます。

かめた=タートル!作る。
「かめた!100 歩く 120 左回り。」!3 繰り返す。
三角形=かめた!図形を作る。

最初の行で、「かめた」という名前のかめのオブジェクトを作成。オブジェクトとは「物」という意味で、ここでは、画面上に描かれた画像のことを指しています。

次の行は「100歩あるいて120度左回り」という意味です。これでかめたが100歩分の長さの線を引き、方向を変えます。それを3回繰り返すと三角形を作れます。

「100歩あるいて90度左回り」にして4回繰り返せば四角形になるなど、回る角度や繰り返す回数を変えることで描く図形を変更可能。その後に「図形を作る」を使うことで、かめたにくっついた状態の図形を切り離して完成です。

円を描くときには「円」を使います。先ほどのプログラムで三角形を描いた部分を、次のように書くと半径100の円が描けます。

かめた!100 円。

色の付け方

色の付け方

「図形を作る」で図形を完成させるときに、色を指定すると図形に色をつけられます。例えば上の三角形を描くプログラムで、最後の部分を次のように書くと赤い三角形ができあがります。

三角形=かめた!(赤)図形を作る。

ドリトルで、あらかじめ用意されているのは次の8色です。

  • 水色
  • 黄色

色を混ぜ合わせて、新しい色を作ることも可能です。例えば、ピンクを作りたい場合には次のように書きます。

ピンク=絵具!(赤)(白)混ぜる。

色の混ぜ合わせ方は、「絵具」と「光」の2種類。「絵具」は絵の具を重ねたときの色を作る方法(減法混色)で、多くの色を混ぜると最終的に黒に近づきます。

「光」は、光を重ねたときの色を作る方法(加法混色)で、多くの色を混ぜると最終的に白に近づきます。

他にも、次のような方法で色を指定することも可能です。

  • パレットオブジェクトを使い、3種類以上の色を混ぜる
  • 色を明るくする
  • 色を暗くする
  • 三原色(赤・緑・青)を数値で指定する

ボタンの作り方

ボタンの作り方

ゲームなどのコンテンツでは、画面上のボタンでキャラクターなどを動かせるようにしておくと便利です。ここでは、ボタンの作り方について解説します。

例えば、キャラクターを移動させるボタンを作るときには次のように書きます。

 かめた=タートル!作る ペンなし。
 右ボタン=ボタン!"→" 作る。
 右ボタン:動作=「かめた!100 0 移動する」。

 下ボタン=ボタン!"↓" 作る。
 下ボタン:動作=「かめた!0 -100 移動する」。

ドリトルでは、かめを動かすと線が描かれます。「ペンなし」を使うと、線を引かずにかめを動かすことができます。

ボタンを作るときには、まずボタンの名前を決めましょう。上記の例では、「右ボタン」「下ボタン」などがボタンの名前です。

「→」や「↓」は画面上にあるボタンの中に表示される文字です。見やすさや使いやすさを考えて決めましょう。

動作を指定するときに使っている2つの数字は、1つめが画面上で左右の座標を指定するx軸、2つめが画面上で上下の座標を指定するy軸を表しています。現在いる位置を起点として、ボタンが押されたときにどの向きにどれだけ進むかを決めています。

アニメーションの作り方

ドリトルでは、タイマーオブジェクトを使って簡単なアニメーションを作ることも可能です。例えば、かめが前進しながら線を引くアニメーションは次のように書きます。

かめた=タートル!作る。
時計=タイマー!作る 1秒 間隔 10回 回数。
時計!「かめた!10 歩く」実行。

このプログラムは、かめが10歩前進しながら線を引く動作を10回繰り返すものです。今回は1秒間隔で動かしていますが、動きを小さく、間隔を短くするほどなめらかに動きます。

特に指定しない場合、タイマーの実行間隔は0.1秒、回数は100回です。上記のように書くと、1秒間隔で10回の繰り返しに変更できます。

プログラミング言語ドリトルで作れるゲーム例4つ

プログラミング言語ドリトルで作れるゲーム例

上記で紹介した4つの方法などを組み合わせると、簡単なゲームを作れます。ここでは、次の4つの例を紹介します。

  • 迷路
  • シューティングゲーム
  • ピンポンゲーム
  • 宝物拾いゲーム

例1:迷路

迷路

迷路を作るには、次のようなステップでプログラムを書きます。

  • 1.自由にかめを動かしてコースを作る
  • 2.かめを上下左右に動かせるボタンを作る
  • 3.ゴールラインを作る
  • 4.かめをスタート地点まで動かす
  • 5.ゴールラインに触れたらゲームクリアと表示する
  • 6.壁にぶつかったらゲームオーバーと表示する

コースを作る方法は、上記で紹介した図形を作る方法の応用です。次のように書くことで、動くときに「ペンあり」「ペンなし」を切り替えられます。

かめた!ペンあり 100 歩く。

線が途切れる場所では、「図形を作る」を使ってかめから切り離しましょう。そのあと、かめを上下左右に動かせるボタンを作っておきます。

ボタンの作成は、以下のように書きます。

かめた!ペンなし。
左ボタン=ボタン!"←" 作る。
左ボタン:動作=「かめた!-10 0 移動する」。
右ボタン=ボタン!"→" 作る。
右ボタン:動作=「かめた!10 0 移動する」。
下ボタン=ボタン!"↓" 作る。
下ボタン:動作=「かめた!0 -10 移動する」。
上ボタン=ボタン!"↑" 作る。
上ボタン:動作=「かめた!0 10 移動する」。

次に、ゴールラインを作ります。ゴール部分に線を引き、その線にかめが触れたときにゴールと判定します。

ゴールラインを引き始める位置までかめを移動させましょう。先ほど作ったボタンを使ってもよいですし、次のように座標を指定して移動させることも可能です。

かめた!ペンなし -50 50 移動。

このとき、移動させる数字は自分の作った図形に合わせてください。移動できたら、次のように色の違う線をひいてゴールラインを作ります。

かめた!(赤) 線の色 100 歩く。
ゴール=かめた!図形を作る。

ゴールを作ったら、かめはスタート地点に移動させておきましょう。次に、ゴールラインに触れたら「ゴールクリア」、壁に触れたら「ゲームオーバー」と表示する設定を作ります。

同時に、ゲーム終了がわかりやすいよう衝突時にかめを消します。すべて1つにまとめて、次のように書けます。

かめた:衝突=「|相手|「相手==ゴール」! なら 「自分!消える。 ラベル!"ゲームクリア" 作る。」そうでなければ 「自分!消える。 ラベル!"ゲームオーバー" 作る。」実行。」。

プログラムを実行すると、上下左右のボタンでかめを動かして遊べます。

例2:シューティングゲーム

シューティングゲーム

シューティングゲームの作り方は、ドリトルの公式サイトで詳しく紹介されています。作り方のステップは次のとおりです。

  • 1.敵を攻撃する主役を作る
  • 2.敵に向かって飛ぶ弾を作る
  • 3.複数の敵キャラクターを作る
  • 4.敵の動きを設定する
  • 5.敵と弾が衝突したときの動作を設定する
  • 6.ゲームクリアの条件を設定する
  • 7.ゲームをクリアの表示を設定する

上記のステップに沿ってプログラムを組んでいくことでかめから弾を発射して敵を攻撃し、時間内にすべての敵を倒せばクリアというゲームを作れます。

例3:ピンポンゲーム

ピンポンゲーム

ピンポンゲームも、ドリトルの公式サイトに掲載されているゲームです。次のようなステップで作成します。

  • コの字型の壁を作る
  • 左側の壁とパドルを作る
  • パドルを動かすための上下ボタンを作る
  • ボールの動き方を決める
  • 左の壁にボールが触れたら「ゲームオーバー」と表示する
  • 一定時間経過したら「ゲームクリア」と表示する

上記のステップに沿ってプログラムを組んでいくことで、制限時間まですべてのボールを打ち返し続けられればクリアというピンポンゲームが完成。さらに、ネットワーク機能を使うことで友人とラリーを続けるゲームが可能になります。

協力型ピンポンゲームの作り方についても、ドリトルの公式サイトに掲載されています。作り方のステップは次のとおりです。

  • 壁やパドルを作る
  • サーバーに書き出す情報を設定する
  • サーバーから読み出す情報を設定する
  • 相手とボールの位置を合わせる
  • 「ゲームクリア」または「ゲームオーバー」を表示する

例4:宝物拾いゲーム

宝物拾いゲーム

宝物拾いゲームは、かめを左右に操作して宝物であるトンボを拾うゲームです。上記のゲームと同様にドリトルの公式サイトで詳しく解説されています。

宝物拾いゲームを作るステップは、次のとおりです。

  • かめを動かすボタンを作る
  • かめが自動的に前進するよう設定する
  • トンボをランダムに画面に置く
  • 宝物の拾い方を設定する

ドリトルのゲームプログラミングをさらに楽しむ2つの要素

ドリトルのゲームプログラミングをさらに楽しむ要素

ここまででもゲームとしては遊べますが、次の2つの要素を追加するとさらに楽しいプログラムを作れます。

  • 音楽を流す
  • チャットを作る

それぞれの方法を解説します。

音楽を流す

音楽を流す

ゲーム内で音楽を使う場面は、主に次の2つです。

  • BGM
  • 効果音

長い音楽を作ってゲームスタートと同時に流せばBGMになりますし、かめが壁にぶつかったときなどに短い音楽を流せば効果音になります。

カタカナでドレミを書けば単音での演奏、アルファベットを使えば和音での演奏が可能です。例えば、低いドから高いドまでを順番に鳴らすには次のように書きます。

メロディ1=メロディ!"ドレミファソラシ^ド" 作る。

「^」は、それより後ろの音を1オクターブ上げる記号です。逆に、1オクターブ下げるためには「_」を使います。

他にも、次のような記号が使えます。

記号意味
休符
長音
44分音符
88分音符
1616分音符
{ドレミ}三連符

演奏するときには次のように書きます。

メロディ1!演奏。

複数のメロディを作成して、組み合わせて1つの曲を作ることや楽器を変えて演奏することも可能です。

チャットを作る

チャットを作る

ネットワークに接続すれば、チャットを作ることも可能です。チャットをしたいパソコンにインストールしたドリトルのうち1つで、サーバーを起動しておきましょう。

サーバーを起動すると、同じネットワーク上にある別のパソコンとの通信が可能になります。送信フィールドに入力した文字をサーバーを起動したドリトルに送信するには、次のように書きます。

サーバー!"(サーバーのIPアドレス)" 接続。
送信フィールド=フィールド!作る。
フィールド:動作=「サーバー!"msg" (送信フィールド!読む)書く。 」。

IPアドレスとは、ネットワーク上の住所のようなもの。数字の組み合わせによって表されます。

IPアドレスはパソコンによって異なるので、IPアドレスを使うことで1つのパソコンを指定可能。今回は、サーバーを立ち上げたパソコンを通信相手として指定するために使っています。

2行目では、メッセージを書き込むための送信フィールドを作成。3行目では、送信フィールドからメッセージを読み取り、サーバーに「msg」という名前で書き込んでいます。

このプログラムではリターンキーでメッセージが送信されます。送信ボタンの設置や、送信後にメッセージをフィールドから削除するような設定を加えるとさらに便利です。

メッセージを受信して画面上に表示するには、次のように書きます。

サーバー!"(サーバーのIPアドレス)" 接続。
 受信表示=リスト!作る 300 400 大きさ。
 受信メッセージ=サーバー!"msg" 読む。
 受信表示!(受信メッセージ)書く。

2行目では、受信したメッセージを表示するためのボックスを作成。3行目でサーバーからメッセージを読み取り、4行目で画面に表示しています。

このプログラムでは実行したとき1回だけメッセージを受信する設定ですが、自動的に受信できるよう設定するとさらに便利です。

まとめ

ドリトルで本格的なゲームを作ることも可能

ドリトルは、日本語でプログラミングができる言語です。かめを動かして図形を作り、それを組み合わせて動かすことで迷路やシューティングゲームなどの簡単なゲームを作れます。

さらに発展させて音楽を流したりチャットを作ったりすれば、さらに本格的なゲームを作ることも可能。興味がある方は、チャレンジしてみてはいかがでしょうか。

この記事のおさらい

プログラミング言語「ドリトル」を使って作れるゲームの例とは?

「迷路」「シューティングゲーム」「ピンポンゲーム」「宝拾いゲーム」などです。

音楽を流すときに使える2種類の文字とは?

単音を流すときに使うカタカナと、和音を流すときに使うアルファベットです。

侍エンジニアは「人生を変えるプログラミング学習」をコンセンプトに、過去多くのフリーランスエンジニアを輩出したプログラミングスクールです。プログラミングに役立つ情報や有用な情報を発信していきます。
サービスページはこちら

あなたの目的に合わせた
SAMURAI ENGINEERの運営サービス

SAMURAI ENGINEER Pro

未経験でも挫折しないプログラミングスクール

詳細はこちら

SAMURAI ENGINEER Plus

日本最大級のサブスク型オンラインITスクール

詳細はこちら

SAMURAI ENGINEER Freelance

「一人で稼げる」スキルを身につける

詳細はこちら